Start line:  
End line:  

Snippet Preview

Snippet HTML Code

Stack Overflow Questions
 package org.jruby;
 
 public enum CompatVersion {
 
     RUBY1_8, RUBY1_9, RUBY2_0, BOTH;
 
     public boolean is1_9() {
         return this ==  || this == ;
     }
    public boolean is2_0() {
        return this == ;
    }
    public static CompatVersion getVersionFromString(String compatString) {
        if (compatString.equalsIgnoreCase("RUBY1_8")) {
            return .;
        } else if (compatString.equalsIgnoreCase("1.8")) {
            return .;
        } else if (compatString.equalsIgnoreCase("RUBY1_9")) {
            return .;
        } else if (compatString.equalsIgnoreCase("1.9")) {
            return .;
        } else if (compatString.equalsIgnoreCase("RUBY2_0")) {
            return .;
        } else if (compatString.equalsIgnoreCase("2.0")) {
            return .;
        } else {
            return null;
        }
    }
New to GrepCode? Check out our FAQ X